Muting/Pausing sound while playing IronSource ads on iOS

Hello! I’m simply trying to mute the audio while I’m playing ads. I tried with FMODUnity.RuntimeManager.PauseAllEvents(true), FMODUnity.RuntimeManager.MuteAllEvents(true) and also setting the bus volume to 0. All of these methods do work in the editor and also when I build for Android. The problem is with iOS, as the audio keeps playing nevertheless. Does this have anything to do with and AVAudioSession? Is this supposed to be handled natively by FMOD?
Thank you in advance for any hint.


What version of FMOD are you using?

Could you enable the Development Build option in the build settings:

And have the FMOD logging level set to warning and see if there are any errors being logged that may help diagnose the issue.