Random Pitch on Async instrument Pop


I’m having an issue where whenever I put a random pitch variation on an async sound, FMOD /Unity plays its end with a ‘pop’. I already verified if it’s on zero-crossing.
Could it be the compression setting or something?


Are you using a lossless format such as WAV for the audio? MP3s will add some silence at the beginning of the audio file that could cause issues with looping seamlessly. Also test with “Streaming” turned off if it is turned on.

Are you able to upload the audio file in question to here for me to test? I am able to get looping async instruments with random pitches.

Yes, I’m using a stereo WAV, 48khz file, and with STREAM option off.
Looping isn’t quite the problem, sorry if I didn’t explain right. The sample is an OneShot situation, at the moment of player’s mouse click.

Here’s the file: https://filebin.net/z06bt5yrk4x927lr

I’ve been testing using your file but couldn’t experience any pops. Could you provide a video or a profiler session of this happening?

Sure, here’s the link:

I think I see the problem. If you zoom in really close to the beginning and end of the audio file there’s a small non-zero point in the waveform. This is what’s causing the pops. Add a small fade in/out to the audio file and it won’t pop anymore.

That’s weird. I can’t find any non-zero point in the waveform at the end of the file I’ve shared here.
However, fading in at the start of the file solved the problem. Thanks!
I wonder why is this happening as it looks like the pop is at the end of the file? :thinking: