Unity throws "Bus Not Found" error while Load Event Data At Initialization is unchecked

#1

I have a Unity 2018.3.0f2 project in which I am using the FMOD 1.10.09 patch 2 package. Everything is fine and dandy until I uncheck “Load All Event Data at Initialization” in the FMOD Studio Settings. After that, whenever I activate play mode, the console gets flooded with the following two messages repeated over and over:

[FMOD] ObjectLookup::get : Lookup failed for BusModel: {c0f50e4d-a2cb-40f6-bbc3-fb4229968882}
UnityEngine.Debug:LogWarning(Object)
FMODUnity.RuntimeManager:DEBUG_CALLBACK(DEBUG_FLAGS, StringWrapper, Int32, StringWrapper, StringWrapper) (at Assets/Plugins/FMOD-Unity/FMOD/RuntimeManager.cs:33)
FMOD.Studio.System:FMOD_Studio_System_GetBus()
FMOD.Studio.System:getBus(String, Bus&) (at Assets/Plugins/FMOD-Unity/FMOD/Wrapper/fmod_studio.cs:393)
FMODUnity.RuntimeManager:GetBus(String) (at Assets/Plugins/FMOD-Unity/FMOD/RuntimeManager.cs:962)
FMODUnity.RuntimeManager:MuteAllEvents(Boolean) (at Assets/Plugins/FMOD-Unity/FMOD/RuntimeManager.cs:986)
FMODUnity.RuntimeManager:Update() (at Assets/Plugins/FMOD-Unity/FMOD/RuntimeManager.cs:366)

BusNotFoundException: [FMOD] Bus not found 'bus:/'
FMODUnity.RuntimeManager.GetBus (System.String path) (at Assets/Plugins/FMOD-Unity/FMOD/RuntimeManager.cs:964)
FMODUnity.RuntimeManager.MuteAllEvents (System.Boolean muted) (at Assets/Plugins/FMOD-Unity/FMOD/RuntimeManager.cs:986)
FMODUnity.RuntimeManager.Update () (at Assets/Plugins/FMOD-Unity/FMOD/RuntimeManager.cs:366)

I’ve tried manually loading in sounds’ banks as needed, and I’ve tried removing all sound sources from the scene. Nothing works except to recheck the box. Furthermore, this seems to happen on any project I do this on–I’ve tried it on at least two, and I believe a third one a while back (in an earlier version of FMOD and Unity).

The FMOD->Unity connection type is “Project.” The bank import type is “Streaming Assets.”

Is this a problem anybody’s had before? And if there’s any information I ought to have given but did not, please do let me know so I can give it.

0 Likes

#2

Apologies, not sure how this was missed.
This issue has been resolved in v1.10.10.

0 Likes

#3

Thank you so much. Dang, how did I miss two versions of FMOD? (As of my posting, the newest version is 1.10.11!)

0 Likes