Why does the scatter even spatialise when no spatialisation insert is present?

I have scatter instruments set for an ambience event. I want the event to not be spatialised at all, and for the random panning in the event to not be affected by player position. However, it is.

The scatter events act as though there is a spatialiser on the event.

How do I keep the scatter instruments in stereo without getting affected by spatialisation and causing parts of the event to be panned when others aren’t?

Try setting both the Min & Max Scatter Distance parameter to 0. That seems to prevent random panning.
image

It’s not the random panning I’m worried about, I want to keep that. The problem is that when the event is placed in level, the scatter instruments in the event spatialise and pan based on player position despite the fact that there is no spatialiser on the event at any point.

I see, this sounds like it could be related to something I’m also currently experiencing with Scatterer Instruments within 2D ambient events.
Many of my ambient events are comprised of a single stereo loop, and various Scatterer Instruments all placed on separate tracks. The Scatterer Instruments are being output in 5.1, and I’m using the random pan feature so they are played at a random position within the 360 degree field. The events sound fine when previewing in Fmod, but in-game (UE4) I’m not hearing any of the Scatter Instruments really, just the loops.
Is this similar to what you’re experiencing?

Just found this post in the FMOD Community Facebook page which might be useful.

The Scatterer applies its own 3D Panner (Spatializer) to every scatter, and the attenuation is quite short. However you can override this by placing a nested Event Sound into the Scatterer’s playlist, and giving this Event Sound its own 3D Panner with your preferred settings (even with attenuation disabled, if you so prefer). This will override the default 3D attenuation of the scatters.

Thanks Skaven252, would I also get the same results by simply setting the Min/Max distance of the scatterer instruments to 0, and then placing a random modulator on the panner of that track?
I don’t need to randomise attenuation/distance of the scatterer instruments, just the panning.

Exactly what I’m getting.

As already mentioned, the scatterer instrument will spatialize each playlist item based on the scatter distance settings. If you’re looking to just have the panning randomized but not spatialized, then the workaround is as follows:

  • Set the scatter instrument’s min & max scatter distance property to 0-0
  • Create a single event instrument
  • In this nested event, add a multi instrument with all your sounds
  • Add a random modulator to the nested instrument’s master track’s panner

Thanks for the info Richard.