Error when bulding for Oculus Quest

Hi i get this error when building.

Effect Resonance Audio Renderer could not be found. Check that the project contains the correct native audio plugin libraries and that the importer settings are set up correctly.
UnityEngine.GUIUtility:ProcessEvent (int,intptr,bool&)

Is it someone who knows how to fix this error?


Hi, could you enable FMOD Debug logging on the Unity Tool Bar -> FMOD -> Edit Settings -> Initialization -> Logging Level -> Log and post the log please.

Also what version of FMOD Unity Integration are you using?

Thank you so much for getting back to me, here is the log file.
Also when i googled it said i should add the ressonance decorders in unity audio project setup. But the plugins doesnt show up there. I also have tried to find how to setup fmod/unity properly for developing for VR and ambisonix. Like for example, do i need to change something in the build settings in fmod. I have an pixture how it looks now. THanks again for helping me out :slight_smile: I use the recent version 2.02.08 on windows 11.

2022-10-21-07-23-29_log.txt (101.0 KB)

Thanks for providing the logs.

To add Resonance Audio to Unity follow this link: Releases · resonance-audio/resonance-audio-unity-sdk · GitHub. This will add the Resonance spatializer option in the Unity settings. There aren’t any changes to FMOD Studio that you will need to make to build for Oculus, that is more for optimization options.

Hope this helps!

Thanks for getting back to me.

I have already installed it and it doesnt show up, I tried and reinstall and still doesnt show up.

I started a whole new project and if I add the resonance package as the first package it shows upp. But then when i install the fmod studio integreation it dissapears.


I’ll link you to our docs detailing plugins which uses Resonance Audio as an example under Unity Integration | Plugins.

Let me know if that helps!

I’ve already went through the docs but still it doesnt show in the audio settings in Unity.


Hi Chris,

Apologies for the delayed response.

If you re-enable Unity Audio it shall show those options again. This is not recommended explained in Unity Integration | Troubleshooting. Hopefully this will resolve the issue.

Wohoo that did the trick, thanks alot :slight_smile:
Will this mess something up when building for Oculus if its enabled? Since its recomended to have it disabled.

Thanks for The Great support and an great program thats an joy to work with :slight_smile:

Den mån 31 okt. 2022 03:17Connor_FMOD via FMOD Forums <> skrev:

1 Like

Good to hear it helped!

Only if you are planning on building to Xbox, otherwise it just means Unity audio will consume some audio resources. The effects shouldn’t be noticeable.

Thank you for choosing FMOD, always happy to help!