FMOD causing UE4 crash at startup


Recently attempted to clone a UE4 project, but now both the clone and the original are crashing after loading. Using:
FMOD 2.01.09
Windows 10

Here’s my crash log as well- any help would be amazing!


Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x0000000000000038

UE4Editor_FMODStudioEditor!FFMODAssetBuilder::ProcessBanks() [C:\jk\workspace\Build__2.1__Unreal_Win\integrations\UE4\temp\FMODStudio\HostProject\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODAssetBuilder.cpp:51]
UE4Editor_FMODStudioEditor!FFMODStudioEditorModule::ReloadBanks() [C:\jk\workspace\Build__2.1__Unreal_Win\integrations\UE4\temp\FMODStudio\HostProject\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODStudioEditorModule.cpp:1236]
UE4Editor_FMODStudioEditor!FFMODStudioEditorModule::ProcessBanks() [C:\jk\workspace\Build__2.1__Unreal_Win\integrations\UE4\temp\FMODStudio\HostProject\Plugins\FMODStudio\Source\FMODStudioEditor\Private\FMODStudioEditorModule.cpp:387]
UE4Editor_FMODStudioEditor!TBaseFunctorDelegateInstance<void __cdecl(void),FDefaultDelegateUserPolicy,<lambda_b89097783886ec9b87f132c6787c1a3c> >::ExecuteIfSafe() [C:\Data\UE4\Unreal Engine\4.26\Engine\Source\Runtime\Core\Public\Delegates\DelegateInstancesImpl.h:838]

Updating here: I’ve found that if I delete the AssetLookup.uasset file in my UE4 project, the project will load with errors but it won’t crash. However, it then creates a new AssetLookup file which crashes the project the next time I load it.

Any help would be amazing, thanks!

I have not been able to reproduce this issue- is there anything more to your cloning process outside of copying and pasting the folder containing your UE4.26 project?

Not to my knowledge. I used the UE4 ‘Clone’ function in the Epic Games menu if that makes a difference. I am also storing my UE project and FMOD project on Dropbox, which might possibly affect things but I have also tried copying the affected project onto a dedicated drive and still get the same error.

Any more ideas here? Not sure what my next steps for troubleshooting this are. Thanks!

Thanks for the extra info- I haven’t reproduced any crashes using the “Clone” function.
Is this a code project or a Blueprints-only project? I am a little suspicious of the Unreal integration version- the line numbers in your log aren’t aligning with anything in the UE4.26 2.01.09 integration. Can you please re-download and install the UE4.26 2.01.09 integration and share a complete crash log? It should be in the “{project}\Saved\Crashes” directory.

Okay, re-downloaded and installed the 4.26 2.01 and I think you’re on the right track. I remember at a certain point during the cloning process UE threw an error that the project had FMOD 2.02 integration and I was using 2.01. I then downloaded 2.02 and that’s when the trouble started. After re-installing the 2.01.09 integration the project loads with a few load errors:

I’m also getting this error on load

I think most of those are my anim notifies that are missing (but safe in a copied folder). However now I think the issue is my FMOD project got updated to 2.02.06 and the UE4 integration is for 2.01.09

EDIT: I found a backup version of my FMOD project in 2.01.09 and I tried building that bank to a clone with the 2.01.09 integration, but still getting a crash. Here’s that log:
DRIVECLONE_RPG2.log (223.4 KB)

Thanks for the extra information- it’s not clear to me where this is crashing from that log.
I think I am going to need a reproduction to figure out why this is crashing and work out some recovery steps for you. Can you please upload this project to your FMOD profile?

1 Like

Uploaded! Let me know if you need anything else- and thanks again for the help.

Thank you for sending that over. I haven’t been able to reproduce a crash with this project, the AssetLookup is valid and has correct entries, cloning the project hasn’t caused any issues.
It did tell me that I had a mismatched editor version when I opened it though, can you please confirm you are using a public release build of UE4.26.2?

Interesting. Just did a verify on my 4.26.2 UE and still getting my crash unfortunately.

Thank you for confirming, worth double checking at least.
I can see your previous AssetLookup entries appear to be corrupt/incomplete, with a size of 4kb. When I build the AssetLookup however it appears to be complete and has a size of 24kb. Can you please confirm this and tell me how big your AssetLookup file is?

I think you’re on the right track, but my AssetLookup looks like it’s also 24kb. I can open the project after deleting the AssetLookup file, though.

Strange, can you please share the AssetLookup file you have after a crash?
I think the best thing to do to get back to a working state would be to completely remove FMOD and add it back in. Can you please try:

  • Delete everything FMOD related from the project, including everything in Plugins/FMOD, Content/FMOD and Save/Autosaves/FMODStudio
  • Re-download the FMOD 2.01.09 integration and add it to your UE project
  • Link to your FMOD Studio project with Help>Validate FMOD.

Gotcha. Uploaded the AssetLookup, and to confirm this is the Project/Content/FMOD/PrivateIntegrationData/AssetLookup.uasset

Will try removing and reinstalling FMOD and get back to you.

Thank you for sending that over- I have reproduced this crash by swapping in the AssetLookup.uasset file. I have also reproduced the succesive crashes after deleting and regenerating the AssetLookup.uasset file.
I have found that rerunning the validation tool has got the project back to a good state. Can you please try the following:

  • Delete evenything in “Content/FMOD
  • Clear your project’s build path in FMOD Studio, under Edit>Preferences…>Build>Built banks output directory (optional):
  • Open your project in Unreal
  • With FMOD Studio still open, run the validation in Unreal by going to Help>Validate FMOD

Hopefully that also works for you. Please let me know if it doesn’t and I’ll see what else can be done.

Hey Jeff!

So followed those instructions and got this error message after running the Validate FMOD command and the ensuing build:


The game also doesn’t play any sound at this point. Upon restarting the game, it still crashes with the same error.

Is there anything in the “Content/FMOD” directory after running the validation tool?

Is that “S:/Dropbox” folder a synced directory? That might explain the file corruption issue- maybe Dropbox is backing up while Unreal is trying to write to a file. Can you please try moving your project to a non-synced directory and rerun the FMOD validation tool?

Moved the project to a non-synced directory but still getting the error. Here’s the timeline:

First popup upon load after cleaning out the Content/FMOD folder:

Next, before I validate FMOD I see that within the Content/FMOD folder I see that I now have the PrivateIntegrationData folder:

I am able to close and open the project without a crash at this point. Next, I run the validate FMOD tool and get this standard notification:

I select ‘Yes’ and then get this notify:

I select okay and the FMOD Studio session automatically runs a build function and UE4 sends me this notify:

Looking in the Content/FMOD folder at this point I now have a Desktop folder and the PID folder:

After clicking ‘Okay’ on the UE4 notify, Unreal reloads FMOD banks and the Content/FMOD folder now has what looks like a full build in there:

The output directory on FMOD Studio is correct and the validation tool says finished. Upon reloading, the project crashes.

I am not sure why is still has the PrivateIntegrationData directory after clearing out Content/FMOD. Can you please ensure that is removed and retry those recovery steps? The bad AssetLookup.asset is in that directory and appears to be what’s responsible for the crash.