FMODStudioCache inconsistent GUID and cached parameter bloat


We’re having problems in multiple Unity projects with a corrupt cache GUID, which bloats the project with duplicate parameter references and it feels like we’ve tried everything to solve it.

I’ve followed the tips shown in this thread and every thread linked there, but haven’t come across any that specifically mention the cache. Deleting the cache doesn’t work, and I’ve tried reimporting FMOD integration 2.01.11, upgraded to latest Unity version 2020.3.22f1, reimported all assets, refreshed modified and selected assets in FMOD Studio, even created a new fresh project where I imported the Settings.cs file from the new project into the old project.

This problem is causing massive slowdown and bloat as it grows each time any member on the team makes a compilation change. I hope someone on the FMOD team can help us out here!

This looks similar to the issue mentioned here and is due to a known issue with Unity. Deleting the Library folder and reopening the project should resolve the issue.
Please let me know if you are still getting these warnings and I will investigate further.

EDIT: Looking at our issue tracker, I saw there is also a known bug which causes these warnings after new events are created and banks reload. This should be fixed in the next release, which should be available soon. When that becomes available I recommend updating and seeing if that resolves your issue.

1 Like

This was a Unity issue that has since been resolved:

Asset Pipeline: Fixed an issue where the Unity version was no longer written to a serialized artifact files that was generated during asset importing. This caused inconsistent import results across Unity versions. For existing projects, users must either do a “Reimport All” or delete the library folder for this fix to take effect. (1310981)

Hi @jeff_fmod

So we’re currently on 2.01.11 Verified by Unity through the Asset Store. Will the next release be such a version as well? What version specifically will this be, 2.01.13?

Tried deleting library and letting it rebuild and still getting the warnings in the console and parameters in cache are growing.

EDIT: Attached another screenshot from another project with the same issue but with a bit more info from the log.

Also added a screenshot of the cache itself so you can see how it has multiple of the same.

Hi @mathew

As stated in original post, we’ve already tried reimporting all assets, and now also deleted the library. We’re on latest Unity version, 2020.3.22f1.

I confirm the issue is resolved in FMOD Integration 2.02 (I believe)

1 Like

We are not planning on getting 2.01.13 Unity verified, the next verified version will be 2.02.04.
I have previously found that having a large number of events in a master bank can exacerbate this issue, do you have many (if any) events assigned to a master bank?

Hi @jeff_fmod

We’ll try the new FMOD version then.

We have a lot of events in the master bank, but even on some smaller projects with hardly any events, I have the issue. And we didn’t always have the problem on our biggest project so I can’t really put the two together, although you’re right that having more events and parameters makes it worse.

Hi @jeff_fmod

Upgrading to 2.02.04 fixed the issue! Thanks for the help, just wish I’d tried that beforehand.

1 Like