Problem with VCA and Snapshots on Android

Hello, we have a problem with snapshots and VCA on Android builds with Unity.
We used at first Unity 2020.3.18f1 and FMOD 2.02.09 and we couldn’t run the game on Android devices because we were full of snapshot and VCA errors when we tried to activate them. Then we upgrade Unity to 2020.3.38f1 but the situation didn’t change: lots of errors in the first scene of the build, always caused by VCA and snapshot’s calls.
Finally, we upgraded FMOD to version 2.02.13 and now we can the app on our Android devices.
The problem is that we still get the errors on VCA and snapshots as before, but VCA calls now effectively change our audio, while snapshots give errors without crashing, but they still don’t do anything.
Do you have some advice for us, to fix this behavior?


I set up a simple scene where I was using a SnapShot to turn up and down a VCA and I was not experiencing any issues using FMOD 2.02.12.

What are the error messages that you are receiving? Are there any reproduction steps you can provide which consistently cause the errors?